Installing LibreNMS

Images

We have some pre-built VirtualBox images you can use to get started. Please note that these images are pre-built for VirtualBox, hence they might not work with other hypervisors without converting them:

Ubuntu 16.04

CentOS 7

Manually

If you want to install manually then we have some documentation which should make it easy.

Please note the minimum supported PHP version is 5.6.4

Ubuntu 16.04 Apache

Ubuntu 16.04 Nginx

RHEL / CentOS 7 Apache

RHEL / CentOS 7 Nginx

Old Install Docs

If the above are missing or incomplete then you can try our old docs below.

Debian/Ubuntu

RHEL/CentOS

Debian/Ubuntu Lighttpd

Debian/Ubuntu Nginx